Airdrop on devnet failed

I am learning how to write a contract on Solana. I just installed the development environment, but I failed when applying for sol with airdrop, and I couldn’t publish the contract on the testnet for testing. It also fails with the same error on devnet. Can anyone know how to get sol for testing?

The error message is as follows:
$solana airdrop 1
Requesting airdrop of 1 SOL
Error: RPC response error -32601: Method not found

My config is below:
$solana config get
Config File: /Users/dev/.config/solana/cli/config.yml
RPC URL: https://api.testnet.solana.com
WebSocket URL: wss://api.testnet.solana.com/ (computed)
Keypair Path: /Users/dev/.config/solana/id.json

Hi @Leon2021 and welcome to the forum! :wave:

I’ve tried the same command with the same URL and it worked. Maybe the servers were temporarily down during a testnet reset or something like that. Maybe try it again and let me know if it still doesn’t work.

hey, @Leon2021, try on devnet. not testnet.

solana config set --url devnet

Hi, zicklag, thank you for your help. I just tried again and still the same error. It seems the server node I connect to doesn’t support airdrop action. can you just help to airdrop 1 sol in devnet to my two wallets, then I can continue developing without being blocked:
solana airdrop 1 7EbNqCKLceWoz8ruHqMKo1yZMwtXnVMfxRiizB62BHor
solana airdrop 1 AfN4GPQtoB5fHTkocYRNDRKRkvQ9X2Vhi8GP7KaqRb4Q

I ping the node and here is the address, maybe this server doesn’t support airdrop:
PING api.devnet.solana.com (128.0.113.156): 56 data bytes
64 bytes from 128.0.113.156: icmp_seq=0 ttl=52 time=510.985 ms
64 bytes from 128.0.113.156: icmp_seq=1 ttl=52 time=532.690 ms
64 bytes from 128.0.113.156: icmp_seq=2 ttl=52 time=553.837 ms
64 bytes from 128.0.113.156: icmp_seq=3 ttl=52 time=483.692 ms

thank you, blockchainlover2019, I tried with devnet and testnet, neither works.

Oh, I just find there’s a website I can request airdrop to my wallet:
https://solfaucet.com/

It succeeds to airdrop to my wallet on testnet, but fails on devnet. Anyway, I can continue with testnet. Thank you all.

1 Like