Can't associate my wallet to seed phrase after reinstall

Hi – Thanks in advance for the help I’m freaking out a bit.

I have two different seedphrases that both allow me to login to Phantom. Strangely, one of them is the same as my Metamask (eth) seedphrase yet still works for my Phantom. I set these up many months ago so remembering exactly what I did or why is difficult. I assume this seedphrase was assigned to me first on Metamask then I was allowed to manually choose my own seedphrase and used it again for Phantom?

At any rate, I have written down two seedphrases that will log me in to Phantom. Both bring up 50-60 wallets. None of those wallets are the one that I staked all my SOL through and holds my handful of NFTs etc. I do know my primary wallet ID (it’s just not showing in Phantom as one of the ~55 wallets that comes up after typing seedphrase).

Is there anything I can do? I’m VERY MUCH HOPING it’s not associated to some third seedphrase that I’ve been unable to find and these other two are just to empty wallets.

2 Likes

Hi @handle993 and welcome to the forum! :wave:

First off: :warning: Warning: Do not reply to private messages on the forum. There are an abundance of scammers who will try to steal your money.

Yes, Solana uses the same seed phrase standard as Ethereum, so a valid Ethereum seed phrase should most-likely work with Solana, too.


The first thing to do is to make very sure that you put the seed phrases into Phantom with no mistakes in spelling or ordering or anything. The easiest way to get lost is to typo something and mess up one of those words.

If you’ve double-checked that, the next thing to try is to try restoring the wallet with a different derivation path.

Does Phantom have a little dropdown that looks something like this one in Sollet, when you are restoring your wallet?

You want to try each different value for that dropdown, which will generate a different list of wallets. The wallet you aren’t able to find might be in one of those different lists.

1 Like

Updates – I independently found information online that it may be a derivation path issue so I tried sollet.io and solflare where I can toggle between 3 derivation paths and still nothing.

I know my wallet ID – is there anyway I can look on solscan or anything to see what derivation path it is on?

Also I staked all my SOL before this BS occurred. Would that have any relevance? So all that is in the wallet is a little bit of USDC or USDT, my staked SOL, and a handful of SOL NFTs. And some BS token that got airdropped to me a long time ago.

what derivation paths did you try? m/44’/501’/0’/0’ is the default phantom path. every time you make a new wallet it increases the first zero by one, so m/44’/501’/1’/0’ then m/44’/501’/2’/0’ and so on. So if you made the phantom wallet then added a new wallet that is how it gets derived.

Thanks – where is the best n00b friendly place that I can try that? I had 4-5 Phantom wallets but I believe the primary was the first one… would creating those others and sparingly using them change anything for tracking down my primary?

1 Like

Addendum –

This is just a completely random wallet – not mine but I’m trying to illustrate my question.

If I know my wallet is [hypothetically] 0xcaBf38deDa833A7Be6d0A7cE0E89DdD5B8730e4A is there some way to look up and see what it’s derivation path is?

1 Like

no. not really. Especially if you used the original as you main wallet. ummm as far as I know, once you get into derivation paths, you are out of n00b friendly waters. maybe someone else can offer a better answer for that…

To my knowledge, no. That is part of the security of using multiple wallets. No one will be able to tell that they all belong to the same seed phrase without the seed phrase, and kind of just guessing what path you used.

is kind of the default, but

is equally valid.

1 Like

Lastly (I will keep throwing stuff at the wall to hope some big brain on here has ideas)

Is there any sollet.bak type file for Phantom that would’ve been created on my computer when I set this up originally? It looks like I tried a sollet.io wallet before switching to Phantom months ago as I do have that sollet .bak file. It is the same as one of the seed phrases I have written down that I’ve been trying and successfully logging in with. Just not finding my wallet yet.

1 Like

If someone helps me get this (not over DM…not entertaining any possible scams) I promise I will give you $200 reward. I’m screwed for right now

1 Like

I suggest taking the seed phrase from the sollet.bak file, importing it into Phantom ( or sollet ) and then adding five accounts.

As you add the accounts, check to see if any of those have USDC, USDT or NFTs in it.

I don’t know any reason that shouldn’t work if that’s actually your seed phrase.