Can't recover my correct adress

I’m not able to get the correct adress of my phantom wallet even though I’m using the correct seed phrase. Recently my ledger device isn’t able to connect to my desktop anymore and I can’t aprove my transactions made through my phantom wallet. So I tried to recover this phantom wallet adress “locked” by my ledger device in order to make it free just like I did with my metamask wallet (and it worked fine). But with phantom I’m facing and enormous dificulty as even inserting the right seed phrase it doesn’t show me the right wallet adress.

Obs: I have 0,004 SOL in this wallet and I just checked all derivation paths trying to find the correct adress unsucessifully. I tried to recover it using Solflare wallet and Sollet.io but didn’t work as well.

Obs2: I’m using my ledger device recovery phrase.

How could I generate the same adress bound to my ledger device in a new wallet?

Here’s something to try:

  1. First install the Solana CLI if you haven’t already
  2. Then run solana-keygen recover -o private-key.json ASK
  3. Input your seed phrase
  4. It will show you the public address that it can generate
  5. If that is correct type y and hit enter
  6. Copy the contents of the new private-key.json file
  7. Go to phantom’s account menu and click “Add / Connect Account”
  8. Click import private key
    image
  9. Paste in the contents of the private-key.json file you copied.

Let me know if that works!


If this post helped you I’d really appreciate a tip, no matter how small, in whatever Solana or SPL tokens you prefer. It will help me spend time helping people on this forum and learning more about crypto. My wallet address is 9ftYTyetEXtLtDkhfRF8bCWGfKZqiYmx2HDZDTogZh6A . Thanks!

Just done that and it didnt work. It keeps generating a pubkey for an adress that isnt the phantom wallet adress linked to my ledger.

Hmm, that’s strange. I’m going to have to look up what derivation path ledger uses for Solana, or maybe see if there is a way to export the private key.

I’ll do some research once I get the chance and let you know.

Thanks! I appreciate your attention!

In the end it was the cable lol. Just got a new one and it worked smoothly. Nevertheless I ordered a second Ledger just in case someday I lose or break it.

I’d like to thank you for disposed some time trying to help me, I really appreciate it!

In regard why I wasnt able to replicate the same adress on phantom that is linked to my Ledger using my Ledger recov phrase it remains a mistery. lol

Hey, well glad you got it working! :slight_smile: