Lost USDT from metamask to sollet using solana bridge

I tried sending/converting 10k usdt using my sollet wallet. I connected to my metamask and began the process. It was approved in my metamask and confirmed on both solscan and etherscan. The tokens never appeared.

A few things:

  1. The USDT wallet (not soUSDT but wrapped USDT) in my sollet says “this is an auxiliary token account.” After the tokens didn’t appear I added another USDT wallet to my sollet. Now I have two USDT wallet. I tried sending 1 USDT to the same wallet and it worked. It’s odd that it worked only after I added the official(?) USDT wallet to my sollet.

I can’t figure this out on my own but it seems to me that the key to this has something to do with the associated account and/or auxiliary account. Please see screen shots below as well as the link to solscan transaction.

I am desperate here as I’ve lost a lot of money and cannot figure this out after over a week of trying. Thank you in advance!!

Hi @marzinga and welcome to the forum! :wave:

@Disheg had run into the same issue before and he said that the Solana devs resolved the issue. I’m not sure if you’ve got the same problem or something else.

I investigated the recent transactions in your Solana wallet and here’s what I found:

  • As you noticed you do have multiple USDT token accounts now.
    • That is technically harmless, though it’s good to consolidate them, because each one locks up a little bit of SOL that you can get back if you consolidate them. I don’t use Sollet very much so I’m not sure if you can do it from inside Sollet, but I know you can do it with the spl-token CLI.
  • The $1 USDT that you tested transferring was just transferred from one of your USDT token accounts to another, so that didn’t really do anything good or bad.
  • It’s my guess that for some reason the Sollet bridge didn’t finish sending the tokens to your address, but they should still be there in the bridge, so I think reaching out on the Solana wallet support channel in Discord is probably the best next step, but…

    :warning: Warning: Be very careful of scams on Discord. Never reply to direct messages and never, ever, ever give anybody your seed phrase or private key.

Thank you so much for responding. The solana wallet discord channel has been completely useless. I think the way to go is work with Serum discord as they developed the sollet wallet in the first place.

I’m also looking to hire a solana dev to help me so if you know of any that would be useful.

Thanks!

Oh, bummer. Yeah, I forgot Serum probably has a discord. That’s probably a good idea. They should be the ones who run the Sollet token bridge.

I don’t know any other devs personally, but I’m looking for work that pays in crypto and while I’m still somewhat new to Solana I have a good grasp on it and I’m learning very quickly. You can look at my GitHub profile or my history here on the forum to get more background on me. I’m currently answering pretty much every question on the forum.

As long as the project doesn’t involve working on artwork-based NFTs. I’m not comfortable with a lot of the artwork people produce so I want to stay away from art projects.


Oh, BTW, looking at your account, you’ve got 30 associated token accounts with a balance of 0, which can be closed to reclaim a total of 0.0611784 SOL which is roughly $9 at the current SOL price. Essentially, any tokens that you’ve had before, but now dont’ have any of will have an empty token account sitting there. Each one takes a little bit of SOL that you can get back by closing the account.

I usually use Solflare to close the token accounts, but Soltricks also lets you do it. I’ve used Soltricks to do it before, but the tool itself seems slightly un-polished, so I would be wary when using it and always double-check the transactions before approving them. The advantage of Soltricks is that it lets you close out multiple accounts in one transaction so you don’t have to pay as many transaction fees.

Thanks. The project consists of somehow finding my usdt on solana bridge and getting the tokens back. Unfortunately I have run out of options and a dev is my last resort.

Ah, I see. Yeah, the only one who can help is most-likely the Sollet bridge folks who have some sort of admin rights to the bridge. Did you ever reach out on the Serum Discord?

believe it or not i cant get into the discord because of a captcha.bot issue that i cant get past without discord support so im dealing with that now. hell of a week!

Ah, I believe it. These crypto communities often have stringent, automatic bot checks that can ban legit users because of aggressive rules. It’s been an issue on the official Solana discord, too.

I’m rarely on Discord, but if I get the chance, I’ll try to reach out to them. Not sure I’ll get to it before you do, again, because I’m almost never got access to Discord, but I’ll let you know if I get the chance.

Sorry about all the trouble you’re having!

Hey @marzinga

I’ve found a way you could try. Last time I went to pancakeswap.finance and then connect my Metamask wallet. It ask to add Binance Smart Chain on this wallet. If you agree. Then you can look for the transaction from where you send the SOL and copy the contract number.

Then, you can use this contract number to import token into Metamask but you need to switch at the top form Ethereum to Binance Smart Chain.

I get mine back… :wink:

Keep me in touch :wink:

See ya !

İs there any progress ?

I had to get a Serum dev to go in and manually get the tokens. He was able to and problem. He said there was an overwhelming amount of traffic that day and for some reason my transaction got stuck on the bridge.

1 Like