My wallet disappeared from my Phantom account

Hi everyone,

Something weird is happening. I haven’t used Phantom for a while ( around 4 months maybe). In between, I changed computer. Today, I have reinstalled the Phantom Chrome extension and entered my seed phrase. When I did, Phantom ‘generated’ around 60 wallets with nothing in it, but my main wallet address, the one I have always used wasn’t part of the list.

6qmPD8e3sXXmtg2woKbE7tQghsJzFgKhcEhCwvgTZTPo

I went to Solana Explorer to check what’s going on with my wallet (there were around 3 Sol in it) but if I understand well, it says that there is no SOL in it anymore. But even weirder, when I inspect the last transaction, it is written next to my wallet address that 'the account doesn’t exist". But I am sure I have never “deleted my wallet”. And I am also pretty sure that I was never hacked, as I really never use Phantom.

Can please someone help me ? Any clue on what’s happening ?
3SOL looks like nothing, but it is still a lot for me…

Thanks :slight_smile:

2 Likes

Here is Explorer Solana capture.

1 Like

I keep seeing stuff like this. Are you sure you got your seed phrase right? Also because the way wallets have been generated has changed overtime, it’s possible that they aren’t generating it the same way as when you got your seed phrase. When I brought this up to phantom, they just said, “oh, we know, but it’s not supported so there is nothing we can do.” That was from the co-founder… Anyways, if you install the cli you can get your wallet back… maybe…

Remeber, DO NOT GIVE YOUR SEED TO ANYONE! no one legitimate will ever ask for it.

last thing. I looked it up on solscan.io and it looks like your wallet is there, just staked–so it looks empty.
let me know if you have any questions.

(post deleted by author)

I am having the exact same issue. had to reinstall my chrome ext do to chrome error but when i went to recover nothing in my wallet? and yes positive the recovery phrase is correct. please help. thanks!

2 Likes

Are you familiar with using the command line? Solana has a great cli, and there is a chance you could use the correct deterministic algorithm to get your money back. I wrote a post on it a while ago, but basically try using first

solana-keygen recover ASK --outfile deleteme.txt

two things, solana-keygen is part of the command line interface (cli) that can be downloaded from solana’s developer page. If you are on windows though, you will have to download the tarball from their github repo, and install it that way. There are instructions for this on the repo and a link to the repo on the solana docs instructions page. Or you can just use linux and it works…

if the pubkey from that command is not correct, you can try some of the newer keygen methods as well…

solana-keygen recover --outfile deletme.txt prompt://
or
solana-keygen recover prompt://?key=0/0 (this is phantoms current derivation method)

to make additional wallets, increment the first 0.
Anyways, this won’t necessarily solve your problem, but it’s something you can try.
Let me know if you have any questions

PS the “Live support page” is a scam. please don’t click the link…

2 Likes

Hi Emery

Unfortunately i have no idea how to do what your saying? does your article walk through it? thanks

1 Like

really the live chat is a scam? are they going to ask me for my seed phrase or something i imagine?

1 Like

Have you tried multiple times to derive your wallet? I recently tried to restore my Ledger wallet in Phantom and when you do it it has the option for what derivation path ( it looks something like m/44'/105'/0'/0' ) to choose.

I could have missed something, but for a second I panicked because it wasn’t generating my wallet address. I tried all of the dropdown options without it finding it ( I think ), then I selected the one I thought it should be again, and that time it was correct!

I’m not sure if this actually happened how I thought it did, or if I just accidentally click the wrong dropdown item a couple of times, but I’m wondering if there’s a glitch somewhere that’s causing all these users issue.

It seems to be happening common enough at this point that something seems amis. And it seems like the Phantom folks aren’t the most helpful unfortunately. :confused:

Another suggestion is to try restoring your wallet through the Sollet wallet. Which has multiple options for the derivation path, including all the ones I know of that have been used in Solana wallets other than the ASK mode, which can only be derived on the commandline.

I’m pretty sure there’s never been a GUI wallet that generated wallets in the ASK mode, though, so I don’t think there’s any reason the commandline should work if none of the Sollet derivation paths work.

So sorry for all your trouble. I’m still not sure why this is happening, unless it really is a Phantom bug.

Yeah it’s the solana-cli that still generates new wallets in ask mode. its a pain, but you can convert it to the correct derivation.

Yes. They send you to a website that looks very similar to solana’s, but it’s a fake, then they ask you for sensitive info in the chat box. They stopped talking to me though after they realized I was trolling them, so IDK exactly what their game plan was…

No, I had this happen to me too. But I probably did something wrong XD I’m still pretty new to this.

they have like a 50k bounty if you can figure it out.

1 Like

I’d appreciate it if you returned my funds.

1 Like

This post was flagged by the community and is temporarily hidden.

@ Mayabryson001

stop posting fake forum link and stop trying to scam people scum

1 Like