My wallet is lost?

Please, help me to solve this!

Step 1.
I’ve got new wallet using command: “solana-keygen new -o ~/.config/solana/id.json”.
I’ve got pubkey (wallet address), BIP39 seed-phrase and json-file

Step 2.
I need to restore my wallet on another PC and I use “solana-keygen pubkey prompt://” command with BIP39 phrase from step 1. The result is DIFFERENT wallet address! It’s not my wallet from step 1.

Step 3.
I go to solflare.com to restore the same wallet there and GOT THE THIRD DIFFERENT WALLET ADDRESS with the same seed-phrase from step 1.

It seems that same seed-phrase is the key for a lot of wallets. But how can I restore MY wallet from step one?

Thank you!

1 Like

Hey there!

Fair, warning, I’m still a little confused about some of the wallet recover options myself, but by testing locally I think I found a way you can restore your wallet using the seed phrase.

In step 2 you said that you tried to use the solana-keygen pubkey prompt:// but for some reason that returns a different public key than if you use solana-keygen recover -o outputkey.json and put in your seed phrase.

If you use the recover command, it comes out with the same wallet address.

Hope that helps!


From my investigation so far…

It seems like there are actually many different keys that can be resolved from the same seed phrase. For instance, if I try to use the recovery phrase in the Sollet wallet, for one it gives me three different options for the recovery strategy to use:

  • m/44’/501’/0’
  • m/44’/501’/0’/0’
  • m/501’/0’/0/0 ( deprecated )

What those mean I have no idea. Not only do I have those options, though, it actually generates a bunch of accounts that could come from that. None of which have the same address as the account I originally generated the seed phrase with!

Talk about confusing. I’m going to do some more experimentation to find out what’s going on, but I think the rule of thumb is that you have to restore your wallet with the same wallet program that gave you the seed phrase. ( by this rule I would have thought that the prompt:// thing would have worked with solana-keygen, but apparently that’s different than recover somehow.


Edit: Another tip! :bulb: I’m fairly certain that it will always be possible to recover your wallet no matter what if you have the contents of the id.json file that contains your private key. Importing this key will work on any wallet as far as I understand.

So always keep that key file somewhere!

Thank you so much for your help!
I’ll try to use your hints and come back asap with the feedback.

Thanks a lot!

1 Like

Hi @zicklag, I can see you have been busy around the community helping lots of people out, just wanted to say thanks and hope you keep up the good work! :heart_decoration:

1 Like

Glad I can help! I’m working on figuring the stuff out myself right now and sometimes that’s the best situation to be in to help others figure it out too. :smile:

1 Like

Yeah, it’s a good way to learn and when you post your responses, others in the community like me learn, too.

So, now I can recover wallet betwen solana-keygen and solana-keygen using the seed phrase!
You are great! Thank you so much!

Still can’t move the wallet between solana-keygen and phantom wallet in both directions (even with all possible full-path variables).
I believe it’s because solana-keygen works with BIP39 but Phanton uses BIP44 wallets.

i’ll try to investigate how to do it and come back with some solution.

Thanks!

1 Like

I cant explain why i’m so stupid but there is the easiest way to import solana-cli wallets into the phantom app.

Just copy everything from generated json file ([123, 321, …, 456, 654]) and paste it in Phantom (Add/Connect Wallet → Import Private Key)!

Thank you guys, you are great!

1 Like

I can’t access my wallet help me pls

my account:GhXbdMVkusyBzrwzeknaRqSeJbyP6Z8buuJBwn2Ph6UV

First, when I ask the questions below I do not want you to post anything extra. Never give anybody your seed phrase or your private key.


With that out of the way:

  • what do you have still of your account, if anything?
  • Are you logged into it from any wallets?
  • do you know what your seed phrase was?
  • What wallet did you use to create your account?

I have coins in my wallet
I can’t access my wallet
I know my seed phrases
sollet web

my problem is my seed words don’t match with my wallet I guess it depends on different wallets

my wallet : GhXbdMVkusyBzrwzeknaRqSeJbyP6Z8buuJBwn2Ph6UV

When you tried to restore your account, did you use Sollet web?


Also, I haven’t tried Sollet web app, but I do have the sollet browser extension, and when I try to restore a wallet it has a screen like this with a dropdown for different recover tasks:

You might want to try selecting different options from that dropdown to see if your wallet address pops up in the list after that.

none of this is my wallet mywallet:GhXbdMVkusyBzrwzeknaRqSeJbyP6Z8buuJBwn2Ph6UV

including this

Bummer. :confused: I’m not sure much what other options you have then. I think that should have worked if you put in the correct seed phrase.

The only other thing I can think of to try is to install the Solana CLI tools and then try running solana-keygen recover.

If your wallet was generated by Sollet, though, I don’t think that will work. Still, it’s worth a try.

1 Like

my wallet:GhXbdMVkusyBzrwzeknaRqSeJbyP6Z8buuJBwn2Ph6UV
I can’t find my wallet where can I get help pls

I just found some information on how wallets and key phrases work in the docs and I’m investigating now. I’m going to do some experimentation and then I might have some more stuff for you to try. Looks promising, but don’t get your hopes up yet.

OK, so I’ve learned a lot more about wallets!

Interestingly there are like an unlimited number of different account addresses that you can derive from the same seed phrase. The good news is, @brkcmn, if you truly do have the seed phrase you used for your lost wallet, and you haven’t gotten any of the words wrong, then you should be able to recover the account if we can figure out the derivation path used to create your wallet addresss.

I’ve got a couple more questions.

When trying to restore your wallet using the key phrase, did you try the deprecated derivation path in the dropdown? ( you only showed screenshots of the non-deprecated options ):

image

Also, have you created lots of different accounts in your wallet ( more than 10 )? For instance, using the “Add Account” button:

If your lost account was, for instance the 11th or later account that you created using the “Add Account” button, then it would not pop up in the list when trying to restore your wallet and we can restore it using the Solana commandline.

Also, @dexen , I discovered the reason for the weirdness that you and I noticed when trying to restore your key! Apparently the seed phrase ( and password, if you specified one when creating the account ) are fully sufficient to restore your wallet.

So when running the command solana-keygen pubkey prompt://, the reason that it gave us a different public key than the one that it showed when creating the wallet is that the key shown when creating the wallet is the “master” public key, and typically isn’t used for transactions.

Instead of using the master public key for transactions, it seems like the general practice is to use a derived public key which is useful for privacy’s sake. Essentially you can have any number of keypairs generated from your seed phrase, and each one has a different derivation path. When using the prompt:// syntax in the CLI, it defaults to using the derived key with a derivation path of m/44'/501'/0'/0'.

This is the address that most web wallets will use I think, which explains the difference from the CLI address when creating the keypair. If you wanted to use a different derived address than the default, in the CLI you can specify a different derivation path by using this syntax: prompt://?full-path=m/44'/501'/1'/0'.

This lets you control any number of different accounts, without having to remember/store different seed phrases!

This is actually very cool, it’s just rather confusing.

1 Like