My wallet is lost?

no, when I run it now, it generates me a new private key

OK, so, when you run solana-keygen pubkey ASK it will show you the public key that has your funds in it on the mainnet?

yes exactly, it’s showing me the pub key that has my funds in it on the mainnet but I’ve mistakenly edit the last figures in the private key when editing the code. so when I try to transfer the funds to my constudian wallet, it’s giving me error message based on the fact that the private key mistake I did

Then try running solana-keygen recover ASK -o key.json. This should put a key.json file in your current directory. The command should also say “recovered pubkey” and print out the same public key that it gave you when you ran solana-keygen pubkey ASK.

Then make sure that your Solana CLI is pointed at the mainnet beta by doing:

solana config set --url https://api.devnet.solana.com

Finally, you should be able to see your balance by running

solana -k key.json balance

yes, I tried running it now and it says: Wrote recovered keypair to key.json

with the pub key.

but you said I should config to mainnet, but the command you gave me

solana config set --url https://api.devnet.solana.com

is devnet @zicklag

is that a mistake?

:man_facepalming:

My bad. Sorry. :slight_smile:

solana config set --url https://api.mainnet-beta.solana.com

No problem sir.

am running this: ```
solana config set --url https://api.mainnet.beta.solana.com


now. is that the right one?
1 Like

No, looks like it is a dash between mainnet and beta, according to the docs:

solana config set --url https://api.mainnet-beta.solana.com

Very good. thanks.

am on it now. please hold on.

done now. says: Commitment: confirmed

please, how do I transfer it to my custodian wallet?

You are able to see your balance now, right?

yes exactly. am able to see my balance now

after typing: solana balance

Yay! :tada:

Now you can transfer it to whatever address you want by running:

solana -k key.json transfer [the public address you want to transfer to] [the amount of SOL to transfer]

To be safe, I would recommend transferring a small amount out first, to make sure it went where you wanted it to, and then transferring the rest if that works.

Be very careful to copy-and-paste exactly the correct address.

on it now, please hold on a while

I didnt’ receive the sol I sent and it already says success in the solana blockchain explorer

yes it’s Binance

Oh, I never knew they were causing problem

should I send to my trust wallet instead? And have I lose the funds I sent to Binance?

Okay, than you so much.

but now, I tried sending to my trust wallet, but this is what am getting:
The recipient address (39y***) is not funded. Add --allow-unfunded-recipient to
complete the transfer

what does this mean?

yes, am very sure it’s my wallet address. how can I overide the error?

and if my wallet is not funded, hope there’s no issue with transfering the funds to it right?

cause I have 0 sol in my trust wallet

i don’t seem to understand your last message.

okay, my current balance is 3.731145 SOL. how much will be okay to transfer?

I tried sending (3.73, 3.72, 3.71 SOL), and I keep getting this error

Error: Account ***fUDtF26tT4XZZQ2 has insufficient funds for spend (3.7 SOL) + fee (0.000005 SOL)

sorry, my bad :grinning: @zicklag

I forget I’ve transferred one as test first. sent out the rest. wwaiting for approval

WOW! NOW I’VE GOT IT. GOD BLESS YOU SO MUCH @zicklag I really really appreciate your time and efforts

whats your telegram or discord id?

I just message you on telegram. please share me your phone number also.

I actually still have another issue regarding deploying nft on the solana mainnet. but don’t want to inconvenient you

1 Like

Who did you send it to? Was it Binance? Binance has been causing problems for lots of people lately, not sending or receiving people’s transactions.

So far, the people that I have seen had problems with Binance have been able to get their funds back by contacting Binance support. Also, you may just have to wait a little bit before it detects it, so probably don’t contact support unless the tokens are still not there after a half hour or so.

Binance support can take up to a week to get back to you, unfortunately, and the amount of issues I’ve seen, at least with Binance’s Solana wallet is very unprofessional and I would recommend switching to a different exchange if you have the option.

Probably. I use Phantom for Solana, but any trustworthy non-custodial wallet should work fine. I don’t have a lot of experience with different custodial exchanges yet, so I’m not sure which of them tend to work better, just that Binance has got a bad track record with Solana.

That means that your Trust wallet doesn’t have any funds in it. The CLI is warning you about this because it wants to make sure you aren’t transferring it to a wallet that doesn’t actually exist.

As long as you are sure that this is your Solana wallet address then you are safe.


You just have to add --allow-unfunded-recipient to the transfer command. Like this:

solana -k key.json transfer --allow-unfunded-recipient [address] [amount]

No there’s no issue. The only thing to be aware of is that if you don’t transfer enough ( it would have to be a very small amount ) your address will get charged rent which will eventually deplete the supply. This is only a problem if you put a very, very small amount though. It once happened to me when I had 0.0000005 SOL in an account. I’m not sure exactly what the minimum amount is ( there’s a way to calculate it, but I would have to look into it ), but if it is at least 0.001 SOL, you should be completely fine.


Just make sure you have at least 0.001 SOL in any wallet that you want to keep using. So you can transfer 0.001 SOL to the wallet or any amount higher than that and you will be fine.


Awesome! :partying_face:

So glad I was able to help! :smiley:

You’re the first person that I’ve actually been able to help get their funds back. Usually it’s, “sorry your funds are lost”, or “sorry you’ve got to contact Binance support”. :slight_smile:

I’m not connected to Discord at the moment and I can’t remember what it was, but my nickname is @zicklag on the Solana Discord, and I’m @zicklag on Telegram, but I’m new to Telegram so I’m not sure if you can contact me through my nickname. Also, I’m not usually online on Discord or Telegram.

Anyway, I’m almost always here on the forum, too, ( in my daylight hours ) which has direct messages if necessary.

Hi ziklag. I have a similar problem. My pc was corrupted and when it recovered i had to recover my sollet wallet. I have 2 kinds of coins in my account Sol and the coins I minted. If I restore sollet from seed phrase I cannot see my master account address or my coins.

So I have followed all steps above this point and I can see my address is correct

So I think im just not signed in. Is there anyway to open the master account in sollet? Or how do I log in so I can transfer funds?

got it already. Just took the file key.json renamed it as id.json and moved it to the correct folder

Now I just need instructions to transfer the other (not sol) token from cmd. Or need to access this wallet in sollet

Ok I just opened the key.json in notepad and added the string of numbers from private key to add acct link in sollet and voila! its all back my coins and SOL. Ziklag I would like to contribute something. How can I contact you? Your solana wallet address say its empty and prompts if I’m sure its correct address. Also I have another thing I need help with. I need to add a logo for my token and have had some trouble using github.

1 Like

Very good. Ziklag is a good person. thanks for his help so far.

1 Like