Please Help - My Wallet Address Mysteriously Changed

Hi there

Very strange occurrence. I know this is supposed to be impossible but nonetheless… I hadn’t logged into my Phantom wallet for a couple weeks and then when I did again my balances are all gone and the address is completely different.

I removed and readded the wallet with recovery phrase and same result - no balance, new address.

Thought maybe it was as bug so checked via raydium and then the explorer but still no balance.

Went to binance to find the last time I sent funds to it and found the address - this is how I discovered it’s completely different now. I checked the address from binance withdrawal history in the solana explorer - lo and behold there is my balance!

I’m so confused because this new phantom wallet address is letting me add it with my original recovery phrase. I tried a different browser just to be sure but same new address and apparently no way to access the original.

original address:

4XTT14P2ZGDtTRF3GyVyDYCM1b17c6s8pNG43h6Kk5qx

new address:

81iuoyaxJMmLbVxJCx3yYXN3KTy8mWkq36ZHeGCg4xde

Doesn’t make any sense at all…

o_O

1 Like

Hi @Osyr1s and welcome to the forum! :wave:

If you truly do have your seed phrase, then we have a good chance of being able to recover your wallet.

First off, anything I say does not in any way mean I want you to send me or anybody else your seed phrase or private key. Never give anybody either your seed phrase or private key.

I know how you feel! That was my first thought when I ran into similar trouble, and you can find a couple topics on the forum here where me and some other users were exploring the mystery of multiple addresses derived from a seed phrase.

In fact, an unlimited number of addresses can be derived from one seed phrase, but, to spare you the rather lengthy explanation, let’s just get right to trying to find your original address.


Here are some questions for you:

  1. Where did you initially get your seed phrase from? Was it Sollet, Phantom, the Solana CLI, or something else?
  2. When you logged into phantom again, after not logging in for a while, did you have to re-import your seed phrase, or did you just put in your Phantom password.
  3. Do you have the Phantom browser extension automatically updated
  4. Have you ever used this button in Phantom?

Hi Zicklag

Thanks for responding - mucho appreciato. To answer your questions:

  1. I initially got the seed phrase from Phantom when setting up the wallet for the first time.

  2. I had to re-import my seed phrase because Phantom was not accepting my password which I am also supremely confident I was entering correctly. I was only able to do this by removing the extension from the Brave browser first as the “Remove Wallet” button was greyed out.

  3. I haven’t manually enabled automatic updates for the Phantom wallet so if it’s a default setting then yes, but I don’t see any option for this in the Phantom wallet extension or in Brave.

  4. Clicked that button once to see what it was but never used it because I’ve never exported a private key.

Thanks again.

1 Like

That’s really strange. :confused:

OK, another question, what token type did you transfer? Was this SOL, or another token?


If you were transferring SOL tokens, the first thing we can try is importing your seed phrase into Sollet, which has the option of importing your key and showing you a bunch of addresses that could be generated from your seed phrase, so we can see if your original address shows up in that list.

:warning: WARNING: Always double-check URLs, especially when using new wallet software, because people will try to scam you by pointing you to fake wallets.

You can use Sollet to try to import your seed phrase by using either the web interface, or the browser extension. The web interface URL from the official git repo ( which is under the reputable Project Serum organization ) is https://www.sollet.io/. I’m giving it to you like this so that you can verify that the link is valid and is the real, honest Sollet wallet.

If anybody, even me, tells you to use a specific wallet or to put your seed phrase into anything be very cautious and assume everybody is trying to scam you. Double-check everything.


To import your key into Sollet, open the Sollet interface and click “Restore existing wallet”.

Once you put in your seed phrase and optional password ( the password does not need to be the same as your password in phantom or anything ) Sollet will show you a list of addresses and their balances that can be generated from the seed phrase.

If one of those addresses has your funds, then we’ve found it! If not, try clicking the dropdown that the red arrow is pointing to. You need to try each option in that dropdown to see if your address can be found with any of the different options.

You should be able to see for the original wallet in the explorer:

4XTT14P2ZGDtTRF3GyVyDYCM1b17c6s8pNG43h6Kk5qx

I originally transferred $SOL into it then I believe it was $SOL > $USDC > $ATLAS.

Haven’t moved anything since discovering the new address:

81iuoyaxJMmLbVxJCx3yYXN3KTy8mWkq36ZHeGCg4xde

You will have to be the one to try and import your seed phrase into Sollet, though, to see if any of the addresses that it can generate from the seed phrase match your original address.

I think the receiving address might be different for different kinds of tokens, even in the same wallet. Are you able to see USDC and $ATLAS tokens in your wallet right now, with the new address?

No. As I’ve mentioned already, the new address has no balance. Only the original address shows balances. I can see all of the token balances in Solscan.

None of the addresses in any of the derivable accounts showing on sollet.io are the correct one.

I tried solfare.com aswell, none of the derivable accounts show any addresses matching the original. All have no balance.

Bummer, that’s not good. I can’t figure out what must have happened.

Somehow the seed phrase you have now is not the one that was used to generate your original account.

I’m not sure if Phantom glitched out somehow and generated a different seed phrase and password, but the fact that the account still holds the funds makes it seem like it wasn’t a hacker trying to steal them from you.

If I get the chance I’ll try to investigate the addresses and transactions on Solscan and see if I can find anything that might give a clue, but I don’t think I know of anything else to try.

You can try contacting Phantom support, or reaching out to the Solana Discord to see if anybody else has any more advice, but as always:

:warning: Warning: Telegram and Discord and other messaging platforms are a haven for people trying to scam you. Never give anybody your seed phrase or private key. Even support officials and admins will never ask for your seed phrase or private key. And never use a wallet app that you have not used before if somebody asks you to. They will fake a real wallet and use the fake wallet to steal all of your tokens.

Sorry about your lost funds, and wish I could help more!

No, the seed phrase is 100% exactly the same as the one used to create my original account because I’ve only ever created one wallet and I don’t have any other seed phrase. It’s still written down on the original piece of note paper I used when I created the wallet. I mean unless my dogs are secretly planning to steal my funds and know to write/use a computer then I haven’t been hacked because, correct me if I’m wrong, it’s impossible to have the same seed phrase for a completely different wallet.

Phantom support were my first go to but just blamed the issue on me mixing up my seed phrases by mistake, but again, I only have the one.

Thanks for trying to help anyway.

To my knowledge it’s impossible to have a different wallet with the seed phrase and same derivation path. So unless Phantom was initially using a totally different derivation path than is standard, you should get the same wallet.

Maybe it was an internal error in Phantom that caused it to use a different seed phrase than you entered. :man_shrugging: I don’t know.

I’ve heard another user with a similar issue, but never figured out the problem. Very strange. You may want to look into using a hardware wallet for larger amounts of funds in the future, for extra security.

Anyway, sorry 'bout that, and good luck with your further crypto endeavors!

I had the same issue, anybody had the solution? Thanks

Sorry, no. I’ve tried a few CLI functions with my seed phrase to verify but it just keeps coming back with different addresses to the original. I’ve tried verifying the original wallet address against the seed phrase and it fails.

I’m 100% confident that I have recorded the seed and pass phrases correctly in the beginning, I’m anal like that, but I still can’t access the wallet. It’s just gonna sit there and eventually moon and be the trade I was never able to cash in on.

I have however lost faith in both Solana and Phantom.

Probably the only thing that will satisfy me now is if $ATLAS rugged or tanked and never recovered. Lol

For what little it may be worth, this would be a Phantom bug, and nothing is wrong at all with Solana.


There’s maybe one more thing that I can try, but it’s not likely to work. I can create a tool that will take your seed phrase and brute force try out all the different keys that it can generate from that seed phrase and see if your previous address is anywhere in there.

Again, it’s not likely to work, because, unless there was a glaring bug in Phantom, or some browser extension or malware on your computer trying to manipulate Phantom, that seed phrase absolutely is enough to recover the address and Phantom should have worked first try. ( to my knowledge which so far has not proved inaccurate )

I’ll try to make a brute-force key finder tool and get back to you once it’s finished.

It’s okay. You can stop. I have the wallet back. I did mix up seed phrases from two completely different networks. I wouldn’t have thought a Metamask seed phrase would work in sollet.io but it does somehow. I’d like to say that I’m just stressed out from fighting my employer over covid ignorace and vaccine mandate facing potentially losing my job because I won’t inject myself with a poison death shot and say that that’s why I screwed up, but I simply screwed up whatever the reason and I should just own it. Really appreciate you going to so much trouble to try and help me out.

Faith restored in Solana (and a little bit in humanity because zicklag is an awesome human).

1 Like

Yay!

:tada: :tada: :tada:

So glad you got it back!


Yes, most if not all of the blockchains actually use the same standards for wallet keys. They just use different derivation paths. It’s all according to the Bitcoin standards called BIP-0032 and BIP-0039.


Also sorry about all the stress. I’d say it really sucks, but that’s an understatement.

Anyway, glad the mystery is solved, and wish you the best of luck. Praise the Lord!

I’ve just experienced the same issue with my Phantom wallet changing addresses.

My old address was:
4D4JKnoVzZM2w1TJ4yFkakELWPK3nz3VDJCmiyRcp79R

My New Address is:
68hkov4Wd34NuMfRAYKSBLqQw63oZFr8eRKmzNtXRmJd

I know it’s changed because I saved the old address in my FTX account when I created the Phantom wallet.

And then today I sent Sol to the wallet via FTX, it didn’t arrive and I saw that the wallet address had changed and my sol is sat in the old wallet address.

However I follow the above steps with my recovery phrase however it doesn’t find the wallet address on Sollet, Phantom or Solflare.

I’ve reached out to Phantom but not sure what else I can try?

I’m really not sure. If none of the above worked, then I’m pretty much out of ideas.

It really should not have changed, assuming you took all the steps above and you’re positive that you are using the same seed phrase.

Sorry about that. :confused:

I recommend double-checking that the address you sent it to wasn’t accidentally one of your friends or somebody you’ve paid before or something like that. Most-likely this is not a bug, but some kind of mix-up that happened somewhere.

Yes I’m double/triple checking.

I took a photo of the seed phrase at the exact time that I made my first Solana transaction to this wallet. The time stamps on the photo against the transaction are within 5 mins, and I haven’t used any other wallets. If I look at the transaction history on the old wallet address, it 100% maps to the transactions I have made to the Phantom wallet.

That’s why I’m so confused! I realise human error is 99.99% usually the cause, but I’m at a loss to explain how this could have happened without it being a bug with Phantom.